HitFilm 3 Pro quitting unexpectedly on export

I'm running Hitfilm on an iMac (27-inch, Mid 2010) not super tech smart so here is everything on the About this mac tab:

Processor - 3.2 GHz Intel Core i3 Memory

Memory - 12 GB 1333 MHz DDR3

Graphics - ATI Radeon HD 5670 512 MB

and I'm running OS X Yosemite version 10.10.2


Recently started having trouble exporting any project I have. These are just fifteen to thirty seconds in length and are 1080p, I also can't export it as 640x640 for instagram. After hitting the export button it seems to work normally for a few seconds then just quits, earlier the past few times I tried it brought up an error saying something about being unable to initialize a renderer, I don't really remember because I can't replicate it, it just crashes. Any feedback would be much appreciated and with some help I will find out anything else you guys might need to know in order to help.


  • AdyAdy Staff


    As the software has been working fine up until now, I have to ask has anything recently changed?

    Could you try creating a new user account on your Mac & attempting the export again on the new account. Does it work?


  • Nothing seems to have changed. I mean I had exported a sound effect test just thirty minutes before it started acting up. Every now and then it would freeze and I would have that spinning ball show up and I would just force quit and reopen but I always figured that was just my computer being sub par. I just tried making an account for exporting, got a little lost and had to figure out a work flow for relinking  files but it is working. Is this just what I have to do now to export or will this just be a temporary work around? Thank you so much by the way, this is a huge relief. 

  • AdyAdy Staff

    I only ask as because for the software to work then suddenly it does not is odd. Usually an update has been applied or another piece of software has been installed, but not in every case of course. :)

    The creation of a 'test user' account is to eliminate other software as the root cause. When you create a new user account nothing else is usually running, so your account is clean, so if the software works it usually points towards something interfering with HitFilm.  As it's working on the test account, it might be worthwhile checking what is currently running on the main account & disabling / shutting down any unnecessary processes.

    If you have any further questions please do get back in touch & do keep me posted on any progress you make.

    Many Thanks,

Sign in to comment

Leave a Comment