Direct youtube upload username and password failing

edited February 2015 in Express Support

I just logged out of youtube and then logged in again to make sure I had the email and password correct. I do, and logged in successfully.

When I enter those exact same details in HF, it fails to log in.

Any advice on what I am doing wrong?

It'd be kinda cool to have a check box like [x]hide characters, so you can see what password you have typed in but hide the characters if there's an FBI or MI5 or CIA or ASIO agent standing right behind you.

And I already asked to remove the required attribute on all the meta data that youtube itself does not require when uploading a   video. The youtube video I manually uploaded for the mask redraw weirdness was going to be categorised under cars and trucks if the upload from Hitfilm had worked.


  • edited February 2015

    I had contacted support regarding this.   They told me to reinstall hitfilm (something I really do not want to do unless I have to do something different in the installation.)

  • This might also have something to do with google's security policies. Google blocks login attempts from 3rd party tools if they're suspecting them to be less secure, judging by the authentication method. have a look at this page:

  • @Robin ah, I was looking for this page this morning but couldn't find it. It turns out that it is hidden when the 2-step verification is activated.

    @aarondc Alternatively, if you don't want to turn off the YouTube security feature, you can activate the 2-step verification and generate an app password that you use only for HitFilm.

  • There's this link which goes into detail on Google's 2 step verification, in case you're wondering:

    A few people have had this issue, and we can attribute it to this 2 step verification, so @aarondc let us know if this works. 

  • Cedric has it right.  It took me a quick walk through the two step process then using Cedric's app password link I generated a Hitfilm password, plugged it into the export screen and the upload worked.


Sign in to comment

Leave a Comment