Mask redraw weirdness

Under the pump to try and get this video sorted, but I have a grey plane with a mask "add" to reveal a square of grey, upon which I hope to place text.

I want to add some feathering on the edge like Axel did in his tute and as soon as I start drawing a new mask, the existing one stays where it is, but the display FUBARs royally, redrawing the existing mask 80% off the RHS of the screen.

Incredibly frustrating. As soon as I hit play it redraws properly, but when you're trying to line things up, it is (*)&AS(^DS&^*^*&

Which app should I download in the future to screen cap this sort of weirdness?


  • and FRAPS both have free screen recording options. If you have a modern NVIDIA GPU you can also use the built-in Shadowplay feature. There's also Camtasia, but it's expensive.

    I'll point the devs at this, but in the meantime, the inevitable question: are your graphics card drivers up to date?

  • Bought the card (AMD R9 290) yesterday. Checked the Gigabyte website and their latest driver is dated 2013. The installed driver from AMD is from 2014.

    I found this confusing,  but figured closer date was more recent was more gooder?

  • I'm not as familiar with AMD cards, but certainly for NVIDIA cards I go straight to NVIDIA and bypass the branded manufacturer.

  • So I did the autodetect thing from AMD. And then quickly quit the installer when I realised I had just agreed to install all the utter BS they slip in there like a disease you can never really be cured of.

    Why. Why do they do these hateful things when all you want is a driver.

    Anyway will try again.

  • Download the full package manually and make sure to choose the advanced/customize option when you go to install. This will give you the option to not install certain things if you like. You might find some of the extra stuff useful though as I know one of the extras includes a screen cap utility like ShadowPlay. Some of the other extras have to do with OpenCL enhancements and AMD's GCN platform which can really make a difference with GPU accelerated plugins and such

  • Thanks Aladdin. I will re-read your post after I have had some sleep and am capable of rational, logical thought :D

  • I have the latest AMD driver installed, and tried a new project. Masks work fine.

    Opened my Film riot commercial project and the masks jump around still.

    Going to see if I can do a screen capture of the behaviour :D

  • CPU: Intel i7-4970K @ 4GHz
    RAM: 32 GB
    HDD: Samsung SSD 840 EVO 250GB
    GPU: R9 290 4GB (Driver: Advanced Micro Devices, Inc. 14.501.1003.0 - 20/11/2014 - downloaded and installed today)
    OS: Windows 8.1 64-bit

  • Like I said: I created a brand new project and it didn't happen.

    Also: when I make changes to the scene, the viewer often does not update until I mouse over it. Was very confusing to make changes and have nothing happen. Until I worked out the changes were happening but not being displayed. I soon developed a mouse move after each change workflow...

    Project in question has ~5 still images, about 7 MTS videos and that's about it. Let me know if I can upload / email something to track down the reason for this app behaviour.

  • Any game capture app should work in a non game. Just start it. 

    Brw,I use BB Flashback. There's a free version that's very functional. 

  • AdyAdy Staff
    edited February 2015

    @aarondc - Please try not to post multiple times in the same thread, I have removed some of the posts as they weren't really helping solve this issue. :)

    If you have a Project that you can upload that would be great, it might be something we can then diagnose & fix. 

    Sorry for the inconvenience caused. 

  • Sorry for annoying you, Ady.

  • @aarondc - Not annoying me at all, I just like a nice tidy forum. :)

    Are you able to upload the Project for us?

Sign in to comment

Leave a Comment