Game recordings missing end of clips

edited January 2015 in Express Support

I don't know if this is a problem on my side or HitFilm's side, but whenever I import a clip into HitFilm, it automatically loses about half of the clip. For example, I have a 2 minutes and 2 seconds clip. When I import it into HitFilm, it suddenly lasts only 1 minute and 7 seconds. I have done it multiple times with the same clip, and the amount trimmed stays the same. If I try a 15 second clip, it suddenly becomes 7 seconds. Suggestions appreciated!


  • This sounds curious, and like a possible bug. Did you test it with different video clips? If yes, did those all have the same codec, or different ones? What happens when you place the video on a timeline - does it get cut off only at the end, or does it get sped up?

    It would also be helpful if you could upload a sample clips which shows this behaviour for you, so we can have a look at it. Also your system specs (CPU, RAM, GPU, OS) will help.

  • So, I did test it with different video clips, although I think it may have to to with the video codec. I say that because, when I import clips recorded from Minecraft, it cuts them, but when I import clips from a Canon 70D, it didn't cut them. Now, the problem may have just arisen, because the Canon 70D clip was the first clip ever imported into my HitFilm. To record Minecraft, I use the screen recorder FastStone Capture. ( I am pretty sure they have different codecs. I tried importing more footage from the Canon 70D and from FastStone Capture. The 70D footage is fine, doesn't get cut off at all. The FastStone Capture footage always cuts off about 1/2 of it. When I place it on the timeline, it stays cut off, but does not speed up. I cannot upload the 70D footage, for privacy reasons, but I can upload the Minecraft footage, however I am going to mute it. Here is the download link: Clip.mp4?dl=0


    My system specs are: HP Envy 700 Desktop Computer with Beats Audio, 2 TB Hard Drive, 12 GB of RAM, Windows 8.1, Intel HD Graphics Card 4600, 64-bit operating system, x64-based processor, Intel(R) Core(TM) i5-4430 CPU @ 3.00GHz 3.00GHz

  • Just downloaded the video file and tried opening it in several programs. The video seems to have a length of 00:00:16.28, which I assume is the correct length, and this is also displaying and behaving correctly in HitFilm for me. As it seems to be a bug in either HitFilm, codec, gpu or the likes I guess the best thing to do is open a support ticket.

    One possible cause might be your integrated gpu, which I don't even know right now if it is supported by HitFilm. In general, having a dedicated gpu will vastly speed things up with HitFilm.

  • If you just want a quick fix and are not interested in a general solution to this problem, it might be worth trying to convert the FastStone capture into another proper video format before editing. GSpot tells me the file is coded in H.264 mp4, which generally isn't a good format to edit in.

  • Thanks! What format do you recommend? Also, what should I use to convert it?

  • DnxHD is probably your best best if you're PC, Pro-Res if you're mac. YOu can use MPEG STREAMCLIP to convert your footage (It's free).

    MPEG STREAMCLIP download link:

    DNxHD codec download:

    ProRes codec download:

  • What Triem23 said!

  • I have downloaded the streamclip software but do not see the option to convert the footage to the DnxHD format.  Any guidance here?

  • Triem23Triem23 Moderator

    Yeah, sorry--you tell MPEG STREAMCLIP to export to MOV, then set the codec to DNXHD in the export settings, I think. 

  • If your footage isn't long and you have enough space i would convert it to an uncompressed format. You would have less loss in quality and maybe less problems too in this way. You would be working with a much bigger file of course. I was able to import problematic png images files in this way for example into Hitfilm.

  • Thanks for responding to my post...I checked every setting in the streamclip software and did not see any option to change the codec.  Has anyone used this software to do this?

  • @GChambers under the File menu, right now I'm not exactly sure but I think the option is called "export video...". So it's basically rendering out a new video (not changing the codec of the original one), for which you then can choose all codec settings you want. In this case, as said, try mov (maybe called Quicktime movie) or avi and then use the DNxHD codec in that container.

    If you have many files and/or they are quite big, avi might be preferable because of certain limitations the quicktime format has.

  • As a note, I've seen similar behaviour with screen recorded footage created using FRAPS. A portion of the end of the video is inaccessible in editing software (HitFilm, Premiere etc), even though it plays back in WMP fine. A quirk of the codec, I think.

  • Thanks for the info Robin.  Unfortunately, there is no option after saving in either MOV or AVI to choose the DNxHD codec. I looked through every option and did not see that specific one unless it is shown as something else.

  • Triem23Triem23 Moderator
    edited January 2015

    @GChambers I do my transcoding in Vegas.... I've never ever used MPEG STREAMCLIP until 5 minutes ago, and I found the export AVI to DnxHD option in 30 seconds. I'm guessing you were scanning the list quickly looking for "D" for "DNxHD." It's actually called "AVID DNxHD," so you might have just looked right past it!

    To help you out I have two screenshots linked below.

    Open MPEG STREAMCLIP, and import your file.

    Select Export to AVI and look at the "Compression" tab at the top of the window. Select this dropdown menu and select "AVID DnxHD Codec" as shown in this image:

    Next, select the "OPTIONS" button right next to the "Compression" tab. This will open up the options for the DnxHD codec. The "Resolutions" dropdown menu is where you will select your resolution and bitrate as shown in this image:

    Hope this gets you transcoding!

  • @GChambers - have you already downloaded and installed the Avid DNxHD codec? Its not a default option on your system, so it won't show up in any of your software until you have installed the free codec.

  • Ahhh...Okay, I thought I was losing my mind (well at least not yet).  Axel, thank you for the missing piece to the puzzle.  After downloading the codec, it now shows in streamclip.  Sorry for all of the unnecessary posts but I will give this a try now

  • Triem23Triem23 Moderator

    No problem. As long as you get your stuff transcoding, it's all good. 

Sign in to comment

Leave a Comment