Blender Models Importing With Anomoly

edited December 2014 in Pro Support

i5  GeForce 555M  6GB  W7

Hello, HF3P techs. I hate to report this but it does affect a lot of work I've done.

When I import a .obj model, created in Blender, into HF2U I have no problems and it looks exactly as it should. When I import the same model into HF3P there are gaps in parts of the model and you can see inside. If you compare the pics side by side (included in the dropbox link below) you'll see I have the exact same settings in both programs. I also tried a couple other Blender created models and the same thing happens.

I've included a couple screen shots, the model (Battle Cruiser) and the png texture used in my dropbox here:

Thanks for taking a look!


  • I can't get into your dropbox, and know VERY LITTLE about Blender.  But have you tried this for finding gaps:

     A watertight check  exists in Blender 3d and it is called "Select non manifold" in edit mode.

    Perhaps someone more familar with Blender can step in and see if this is a possible solution to Stormy Knight's issue.


  • edited December 2014

    Thanks for the tip, @Rowby. The thing is, if the model loads fine in HF2 then it should do the same in HF3. The model was created back in January and I've used it many times in HF2 and the model appears to be fine in Blender as well.

    I have a space station model that has three torus rings one above, one in the middle and one below. The middle one is almost non-existant. I'll load that one into the lockbox too.

    The Battle Cruiser model is one mesh so it's all one piece. The station has multiple pieces to it.

    It might take a minute or so for the lockbox folder to load after clicking the link. I just tried the link again and it did work.

  • edited December 2014

    Here are the pics of the model problem. Hopefully this link will hold. I'll check back later to see. Select the arrows on the sides of the pics to advance or go back- there are 4 pics total.



  • Please understand that this is pure conjecture...but IF HitFilm were configured a certain way to handle the geometry of OBJ files as exported from Blender...then there exists the possibility that OBJs currently created in Blender are affected by the fact that there MAY have been some modifications in the way that Blender saves models after version 2.70. Blender version 2.69 is their "Long-term" release because it is fully backward compatible with previous releases of Blender. In other words, one could create a model in Blender 2.69 and open it on a computer that might only be running 2.64 with no loss of fidelity to the model.

    All that changed starting in 2.70. In order to move forward with certain features, backward compatibility was broken. Given that HF2U was released for the Mac about the time that 2.68a - 2.69 were available, this may account for your problem. Also, according to a Blender timeline, 2.64a was available around the time that HF2U for Windows originally came out.

    I would submit that one way to test this might be to download an open-source program called MeshLab, export an OBJ file from an older version of Blender (pre-2.7x), import that OBJ into MeshLab and inspect the mesh. Then, export the same model from a newer version of Blender to an OBJ, import that file into MeshLab and inspect that mesh. If you see differences, you'll know that it's not HitFilm but the way Blender is now writing the code for exported OBJ files.

  • edited December 2014

    Pencilandinc . The models were created in Blender 2.68 or earlier (I downloaded 2.72 but haven't worked with it all that much). The models are a little over a year old and I haven't modified them in any way. So I imported the Battle Cruiser.obj into 2.72 and it looks fine- just like in 2.68. Exported it and brought it into HF3P with the same results as before with the little gaps.

    I'm not too keen on downloading any more programs in my laptop right now and think I'll wait until I hear back from the HF team before investigating other avenues. I DO appreciate your suggestion though and have bookmarked the MeshLab sourceforge page for future reference. It just seems to me if it works in HF2 it should work in HF3.

    I'm also wondering if the UV mapping has anything to do with the problem. Some buildings I created in Blender using jpegs for textures work just fine in HF3P. Same thing with the space station I had done in Blender but in an earlier version I used jpegs for the texture. The same station looks fine with the jpeg textures but with the UV texture applied.....well, you see the results above.

    EDIT: I did downloaded MeshLab. If I can figure it out I'll let you know the results.

    EDIT 2: It was easier than I thought. The BattleCruiser.obj looks fine in MeshLab so I exported it and brought it into HF3P. Exact same holes. I'm more convinced now that it's an error in HF3P. Just for giggles, I also imported the MeshLab version into HF2 and no holes.

    hmmmmmmmmmm.   :^(

  • when you export from blender click the option in the obj setting that says force triangulation or something like that, hf3 didn't seem to like dense meshes that were quads and I got gaps when I was testing a while back, doing the convert to triangles before uploading to hf3 fixed it.

    Might be same issue for you, saying that neither of those obj files import nicely into blender for me either :-) but I did notice what did get imported was quads so it might be that.

  • edited December 2014

    mark_e , but I'm not sure how to do that but I'll keep looking though.

  •  have you got the blend files rather than the obj export I dont mind having a quick look, I can't do anything with the obj files :-)

  • edited December 2014

    Thanks again, @mark_e! I've uploaded the .blend file to dropbox. If you should need the .obj file that's in there too. It should be the first one on the list. Just out of curiosity- which version of Blender do you use?


  • It was that issue with the dense mesh, I use whatever the latest is I think 2.72 at the moment

    Assuming the model is supposed to look like it does ;-) I assume it was a squished sphere massively sub divided with a displacement modifier applied seeing at it's around half a million verts and no visible structure ;-)

    I had same issues when I was trying out auto generated landscapes and importing them into HF3 it doesn't like really dense geometry that's all quads, if you look at the lower left hand corner of the screen shot from blender you see there's an option to tick to force to triangles before export for obj, do that and it will import ok into hitfilm, I've included a new obj file that works and a revised blend file that has basic cycles setup, i don't know how to use blender render engine only cycles!  I added the displacement map back into the glossy texture in blender to give it a bit more detail but looked a bit flat in hit film but not hit film's fault I don't think it's ever going to look amazing because of the geometry.


    Also when you export to obj make sure you keep the .mtl file that's also generated in the same dir as the obj file. that;s the reference to the texture file, you can open it in a text editor and see.

    So yes I think it's  a bug but only with these super dense displacement type generated files and to work around it force triangulation before exporting from blender and it should work as before.

  • edited December 2014

    mark_e !!! I would have never figured that out on my own and your help is greatly appreciated. I do keep the .mtl files in the same folder as the .blend & .obj but didn't know that's what it was for....I just figured don't mess with it if it's there. lol The model is indeed a 'squished' sphere sub divided with a displacement modifier. I learned that process from one of the blender tutorials on youtube.

    So is there a significant difference between blender render and cycles? I haven't experimented with cycles but that is definitely on my agenda for some point down the road. Seeing as how quickly I just rendered another model to correct it using cycles, I'm glad it didn't take you too much time to find the issue and correct it.  :^)

    The blender screenshot revealed to me that I was looking in the wrong place for the triangular faces selector. I will go through all my models today and re-render them. At least I'll be able to move forward from here. Woo-hoo!

    Thank you again and have a Merry Christmas (if I'm allowed to say that) and a great day! You, and the others that replied here, are exactly why the HitFilm community is THE BEST of any forum of which I've been apart. I hope at some point I will have the opportunity to provide some assistance to you guys as well.


  • No problem I'm glad it worked!  I love Cycles i brings out the inner geek in me, takes a bit of getting used to and it's worth putting a day or so aside to read up on exactly how ray tracing works but it's really cool and I love the fact I can properly design materials down to the irq value, fresnel etc I am starting to build up a collection now :-)

    This is def a bug that needs fixing in hitfilm a quad is just 2 triangles so it should be able to do the convert corectly internaly even if the mesh is dense or there are ngons, it's just maths and it should work, I wonder if that's what's causing some of the other glitching with shadows etc. others are reporting, might be worth chucking a couple of those modles through the same process to see if it helps, could lead to the solution.

    Anyway happy xmas! 

  • Thanks to both of you. Multiple heads are better than one...that's what makes this community so great! Happy Holidays to all...and to HitFilming all night!

  • Pencilandinc - "...and to HitFilming all night!"  LOL Wish I could but I have to work tomorrow.

Sign in to comment

Leave a Comment