Green Bar

Hello, I am having a problem with a green bar at the bottom of all video i place into Hitflim; I do not have VLC on my system.  Does anyone know how to get rid of this green bar

Thank You!



  • Do you mean the audio track on the timeline or green appearing in the video in the preview window?

    Are you talking about the VLC media player? If so, why would that be relevant?

  • @PRob  I am taking a wild guess here, but is it possible that your video clips dimensions is shorter on the height than your project settings.  When I have seen video with green stripes and such before in media players it usually is a codec mismatch of some sort. I might be worth checking those settings to be sure, but if not one of the aces will come along to offer help soon, I'm sure.

  • Triem23Triem23 Moderator

    What is your video from? What camera/screen recording? 

  •  Thank Everyone for responding.

    Triem23: It is video that i am referring to.

    THX1139: This is happening on two new computer system.

    4k TdDavis: I will give it a try; thanks again.



  • I just got Hitfilm Express and have the same problem, a transparent green bar on the bottom of the clip.  It doesn't seem to matter what the source of the video is, as I've tried pulling in random clips of varying resolutions.

    Looking at the different color channels reveals more of the problem.  With the red channel the bottom half is mostly completely black, with some tiny strips of the missing image showing up.  The Green channel shows the bottom half of the image brighter than the top half, with strips appearing with the correct brightness.  The Blue channel looks completely normal.


  • @Xodroc What is the source of the video?

    Screen recording? It's variable rate footage and needs fixing.

  • edited September 2017


    MP4 files from various sources.

    I have tried video from my camera as well as random videos off the internet, I have also used Handbrake to make sure my test files are Constant Frame Rate.

    I'm starting to suspect a codec issue, as some ancient AVI files load up fine.

  • Handbrake doesn't guarantee CFR. I put 24fps footage into it to adjust the compression only and get VFR no matter what setting I use to override the frame rate. ShotCut works perfectly with same file.

    Pasting some MediaInfo text of one of the files would help (others) spot the problem.

    Plus the usual CPU, GPU, OS

  •  @Palacono

    Thanks, I'll give ShotCut a try. I think I've narrowed down the problem to AVC streams with MediaInfo.  MPEG-4-Visual/mp4v-20 Streams work even with variable framerate.

    CPU: Dual Xeon E5 2699 V3

    RAM:  128GB DDR4

    GPU: GTX Titan X

    OS: Windows 10 "Pro" x64

    MediaInfo details of the source file I was trying to edit:

    Format                                   : MPEG-4
    Format profile                           : Base Media / Version 2
    Codec ID                                 : mp42 (mp42/mp41)
    File size                                : 576 MiB
    Duration                                 : 7 min 47 s
    Overall bit rate                         : 10.3 Mb/s
    Encoded date                             : UTC 2017-08-16 16:31:02
    Tagged date                              : UTC 2017-08-16 16:31:06
    ©TIM                                     : 00;00;00;00
    ©TSC                                     : 60000
    ©TSZ                                     : 1001

    ID                                       : 1
    Format                                   : AVC
    Format/Info                              : Advanced Video Codec
    Format profile                           : Main@L4.2
    Format settings                          : CABAC / 4 Ref Frames
    Format settings, CABAC                   : Yes
    Format settings, RefFrames               : 4 frames
    Format settings, GOP                     : M=4, N=59
    Codec ID                                 : avc1
    Codec ID/Info                            : Advanced Video Coding
    Duration                                 : 7 min 47 s
    Bit rate                                 : 10.0 Mb/s
    Width                                    : 1 920 pixels
    Height                                   : 1 080 pixels
    Display aspect ratio                     : 16:9
    Frame rate mode                          : Constant
    Frame rate                               : 59.940 (60000/1001) FPS
    Standard                                 : NTSC
    Color space                              : YUV
    Chroma subsampling                       : 4:2:0
    Bit depth                                : 8 bits
    Scan type                                : Progressive
    Bits/(Pixel*Frame)                       : 0.081
    Stream size                              : 558 MiB (97%)
    Language                                 : English
    Encoded date                             : UTC 2017-08-16 16:31:02
    Tagged date                              : UTC 2017-08-16 16:31:02
    Color range                              : Limited
    Color primaries                          : BT.709
    Transfer characteristics                 : BT.709
    Matrix coefficients                      : BT.709

    ID                                       : 2
    Format                                   : AAC
    Format/Info                              : Advanced Audio Codec
    Format profile                           : LC
    Codec ID                                 : mp4a-40-2
    Duration                                 : 7 min 47 s
    Source duration                          : 7 min 47 s
    Bit rate mode                            : Constant
    Bit rate                                 : 317 kb/s
    Channel(s)                               : 2 channels
    Channel positions                        : Front: L R
    Sampling rate                            : 48.0 kHz
    Frame rate                               : 46.875 FPS (1024 SPF)
    Compression mode                         : Lossy
    Stream size                              : 17.7 MiB (3%)
    Source stream size                       : 17.7 MiB (3%)
    Language                                 : English
    Encoded date                             : UTC 2017-08-16 16:31:02
    Tagged date                              : UTC 2017-08-16 16:31:02

  •  Ok, So I tried some of the demo projects that accompany the youtube video tutorials and they have the exact same problem.

    If the MP4 videos the Hitfilm people themselves provide for tutorials have this problem something is clearly wrong.

    I'm evaluating other "free/learning versions" of editing software that open these files up with no problem and also feel silky smooth to work with in comparison.

    The only format that seems to work semi-decently is ProRes.


  • Sorry you are having issues with footage decoding. Does your computer have a Xeon processor?

  • @tddavis , thanks for the heads up.  

    @xodroc I'm having the exact same problem

    @AxelWilkinson  , like @xodroc I'm also running Dual Xeon E5 V3 chips, (Geforce 1080, and windows 10 x64)

    I had sent you a ticket about the issue (IDW-119014)




  •  @AxelWilkinson ; , Yes: Dual Xeon workstation as mentioned above.

    @Gurukast Thanks for speaking up, I've had so many bad experiences with companies not providing support (including those with billion dollar sales records) that that I was pretty much ready to just dismiss Hitfilm as another dead end.

    Many companies just give me some speech about only supporting I7s when in fact the architecture is pretty much the same.  Some will come up with simple patches while most dismiss Xeon's as "incompatible" hardware.




  • I would be intrigued to know how a Xeon would cause a problem.

    I don't think it could be a hardware bug. I've not heard of a posted CPU fault. I remember back in the day, way back, when the Pentium got released with an issue in the FPU ALU. Still a very obscure issue.

    What is easier to believe is that someone could have hand tuned code for various specific CPU(s) with respect to latency and the more obvious extra instructions. The Xeon specifc routine(s) having a bug in the code relative to others. Still an E5 v3 is a Haswell arch chip so pretty recent.

    The ISA is standardized and 3+4 is always 7 regardless of what chip is. This is intriguing. 

Sign in to comment