Bug where keyboard shortcuts stop working until you move a composite layer

I contacted FX Home about the bug where sometimes certain (or all?) keyboard shortcuts stop working until you move a layer. You don't have to move the layer; you can sort of pick it up and drop it again and when you do, the keyboard shortcuts become available again. I know that at least one other person has the same issue and I was hoping for more observations about this bug to pass on to the developers.


  • edited August 2017

    They know about it. It's been in there for a while.

    Nothing to stop you reporting it again to https://hitfilm.com/questions/submit

    Squeaky wheel gets the grease etc. ;)

  • Apparently, although they know about it, they can't reproduce it. I haven't worked out what causes the bug to precipitate. Do you have any idea?

  • Really? Well, F2 for rename often doesn't work immediately after creating a new layer.

    Haven't explored how many other layers are there already or what type of layer, nor what other keyboard shortcuts stop working - if they do - at the same time, but that's fairly reproducible. So consistent  I just tend to not rename things until some time later, or not at all, or do the 'wiggle layer about' trick to get it to work again. I think one of the devs, Cedric?, said twitching tabs worked to restart things. 

  • Hi @Palacono, I'm still trying to figure out the pattern but I've noticed if I click on the Trimmer tab so it's highlighted and then click on a layer in the composite editor timeline and press F2, it doesn't work but if I click on the tab of the composite, then it does. I'd figure that since I clicked on a layer in the composite editor and highlighted it, the tab for that would become active but it doesn't; the trimmer window stays active and receives all the key presses.

    This could be separate issue from what you're experiencing or it could be a related aspect?

  • Could well be something like that. I think there isn't enough 'location awareness' for what's highlighted/active and you think you've selected something with the mouse, but the keyboard was last used in another windows, so that gets the input, or vice versa.

    But definitely report your findings to support as a bug as I think the very nature of it being intermittent is making it hard to track down and fix.

Sign in to comment

Leave a Comment