Doesn't do anything when I click the new project button

My specs:  Operating System: Windows 10 Home 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
Language: English (Regional Setting: English)
System Manufacturer: Micro-Star International Co., Ltd.
System Model: GE72 2QF
BIOS: E1791IMS.111
Processor: Intel(R) Core(TM) i7-5700HQ CPU @ 2.70GHz (8 CPUs), ~2.7GHz
Memory: 16384MB RAM
Available OS Memory: 16296MB RAM



Card name: NVIDIA GeForce GTX 970M
Manufacturer: NVIDIA
Chip type: GeForce GTX 970M
DAC type: Integrated RAMDAC
Device Type: Render-Only Device
Device Key: Enum\PCI\VEN_10DE&DEV_13D8&SUBSYS_11341462&REV_A1
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 11188 MB
Dedicated Memory: 3040 MB
Shared Memory: 8147 MB


Card name: Intel(R) HD Graphics 5600
Manufacturer: Intel Corporation
Chip type: Intel(R) HD Graphics Family
DAC type: Internal
Device Type: Full Device
Device Key: Enum\PCI\VEN_8086&DEV_1612&SUBSYS_11341462&REV_0A
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 8275 MB
Dedicated Memory: 128 MB
Shared Memory: 8147 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: LGD0469
Native Mode: 1920 x 1080(p) (60.006Hz)


  • edited August 2017

    Same here, just purchased Pro and I can't use it because I can't open a new project. Using Express for now but if this isn't fixed I am gonna try to get a refund. 


    Edit: actually now I can't use express either. I tried uninstalling everything then reinstalling. Reinstalled Pro, still couldn't open a new project. So I reinstalled Express and now I can't open a new project there.

    This isn't good, I can't edit any videos now. 

  • Triem23Triem23 Moderator

    @Hiramlll @emdefmek  I'm going to refer you to this thread.

    Pay particular attention to posts from ADY. There's a glitch happening with certain Nvidia cards and drivers, and in the thread ADY discusses the known working drivers while Nvidia and FXHOME work on the issue. 

    Note that recent Windows updates (Creator's Studio) have been rolling back GPU drivers to default. Combine Windows rolling back drivers with the current Nvidia driver having a bug and it's been a big month for Hitfilm issues. Hopefully this will get you up and running. 

    Emdefmek you didn't list your system specs so I don't know if you have an Nvidia GPU, but update  your GPU drivers anyway (because of the Windows issue). Refer to the linked thread if you have Nvidia. 

    If that doesn't fix the issue, contact Support.

  • It worked, uninstalled my driver and installed the nvidia drivers from may ver.382.05 and now everything works. Thanks!

  • @HiramIII @emdefmek There is an issue with the latest NVidia drivers and HitFilm 2017. You can find more details in the following post:

  • Sept. 24, 2017 - I just downloaded the very latest driver from nVidia and it seems the problem has been corrected.

  • My system has Geforce 930MX and the update from Nvidia (Ver. 385.69 created on 16-Sep-17) still haven't fixed the problem for me.  :((


    So, I guess it just have to be the "roll-back and wait" for me now... Hope the Geforce 930MX will get the working update soon.

Sign in to comment

Leave a Comment