Can't drag-drop media into project?..

Is it just me, or am I missing something with HF Pro 2017?

Just upgraded from v4 Pro and went to simply drag a video into the media bin, no joy?  Just now tried a JPG thinking that perhaps it didn't like my MP4.

I can browse to the file and load it fine, but I though you could simply drag and drop media into HF?

Currently doing a repair install just to see if this changes anything...

...Noap, just can't simply drop a JPG?


Any information on this appreciated.



  • @WillBellJr  Just checked this with my 2017 install and I am able to drop dragged JPG, MOV and MP4 files directly into the media bin area?  So I don't think it's a 2017 feature change.  I should mention though that I do still have my previous versions installed in case that made some difference.  Really strange behavior on your install though.

  •  Wow, interesting, I neglected to mention I'm on Win 10 Enterprise.

    I can't see any reason to have HF4P installed in addition to 2017 I have to say.  Admittedly I had 2017 Express installed for a brief period of time just to finalize my decision to upgrade, but I really didn't do much with it.

    One thing that comes to mind is I am using Stardock Fences to organize my icons: Stardock Fences

    Hasn't interfered with any other software I'm using (as far as I can tell).

    I'll try disabling that to see if it makes a difference (and after that I'll do a total uninstall and reinstall as well if that doesn't work.)



  • @WillBellJr  Oh, yeah I'm on Win 10 (with that new Creator update that got forced down my throat!)  I actually have HF3 Express, 4 Express and 4 Pro and 2017 Pro installed .   I'm not a Hitfilm Ace like @Triem23 and @Aladdin4d  and the others, so sometimes someone will ask a question about an older version and I can go into it try and troubleshoot something when the others are busy, busy, busy as they tend to other more pressing issues.  That's really the only  reason to have it like that.  I have never heard of that Stardock program so that and Enterprise edition are two differences that might be the culprit.  Hopefully one of the aces can explain

  • Triem23Triem23 Moderator

    Beats me. Could be the Stardock thing, could be a Windows 10 thing? I'm still on Windows 7.

  • edited July 2017

    Welp, still no joy - disabling Fences, uninstalling and reinstalling (the only thing I haven't done yet is reboot just for GP), but I doubt that'll change anything.

    ...Okay UPDATE - just did a quick search (with the mindset of blaming Win10 instead of thinking it was HF) - turns out the solution is if you set your HF (or potentially any other program) to run as Administrator, for some reason it kills the drag-drop functionality for the target application!

    I just remembered that in the recent past, I also couldn't drop files into an Edius 8.5 Pro project bin as well.

    Saw folks complaining about not being able to drag-drop into FileZilla - that was the clue for me. (Totally weird because I actually d-n-d'd some files to my web server today using FileZilla wo/issue!)

    I often set my programs to run as Admin to eliminate the errors when attempting to save files to USB keys etc.

    Windows 10 does sux I have to say; I've had all kinds of weird issues with it over time, add this one to the list.

    Problem solved for future reference - don't set HF to run as Administrator with Window 10 it will break the drag-and-drop functionality...



  • @WillBellJr  Oh, glad you got it straightened out.  That's weird, though.  So far I haven't been asked to run as admin on my Win 10, but good to now for the future as you say.

Sign in to comment

Leave a Comment