Mocha Pro installer

Hi Folks,

    Just bought the 4th special Mocha Pro upgrade. Went smooth. The download link just leads to the Mocha Download page, with ALL the installers. Obviously the license key is not for the Standalone Pro 5 installer.

Just wanted to be sure which I used for what I purchased. I installed the "OFX" installer, and it licensed with the key I had.

Is this the proper installer to use?

Thanks, Burr



  • Hello,

    Same question from me. Which installer I must download?

    Thanks ahead.

  • "Mocha Pro OFX Plug-In" is the right one.

  • Thanks!

  • edited July 2017

    For me licensing is unsuccessful. After clicking Activate button, HitFilm crashes...

    Windows 7, Intel I7, 12G memory. Some ideas?

  • Triem23Triem23 Moderator

    @JavertValbarr are you 100% certain the OFX installer is correct for MochaPRO? Imagineer doesn't list Hitfilm as a host for the plug-in. MochaPRO standalone can export Hitfilm Composite Shots. It may need to be that version and Muuser may need to contact Imagineer to "Swap versions."

  • By the mocha website, the standalone version is a separate product from the plug-in version of mocha. It's more expensive as well. Stereoscopic 3D is the big thing I see that is extra in the standalone mocha Pro.

    The mocha Hitfilm we have in 2017 is OFX.

  • @JavertValbar & @Triem23 - it works in LE (Learning Edition) mode, so probably OFX is right version, but I can't activate it. Also Imagineer Licence Manager service is unable to start. It must be some kind of local computer based discord. But what kind of...

  • Triem23Triem23 Moderator

    Try contacting Imagineer support? FxHome has nothing to do with Mocha Pro coding. That's Imagineer. 

  • Yes, I know and I will. I already did, but there is no personal touch today. Wrote e-mail and just wait for better tomorrow. :)

    But for little justice - HitFilm also crashes due Mocha plug-in, not only Mocha itself, so I thought that not bad to know that...

  • @Triem23 Pretty sure it's right- we were told the original price was $695, which the plug-in is. It also runs directly in and can only be launched from HitFilm.

  • @JavertValbarr Thank you kind sir!

  • @MuuSer The license manager? You are installing "Multiple Floating licenses"?

    If not, uninstall the license manager and try again. First, uninstall the plugin and make sure HitFilm runs without error, then reinstall the plugin.

  • @BurrManator - yes - I just tried the licence manager as I was unable to activate plugin and unfortunately licence manager did not work either. Service can't be started. Uninstalled licence manager. Removed and reinstalled plugin also. Still can not activated - HitFilm crashes if I click to Activate button, but if I work with it without activation, it works, but of course with watermarks all over the screen...

  • edited July 2017

    Well, clicking activate is heading out to the internet (Probably grabbing Machine and Hardware Data too) Look at your firewall products. Temp disable them. Maybe "run as administrator" for that part.

    If you want, get into your OS specs, video card and such.

  • edited July 2017

    Already disabled firewall, no good. Run as administrator - no good.

    Intel Core i7 X980 3.33GHz
    12GB RAM
    AMD Radeon HD7700 series video
    Windows 7 64-bit Service Pack 1

    I have one doubt. Maybe this is related to Windows user name, as mine is Üllar and it consist UTF character Ü. Maybe this interferes Mocha plugin?

  • edited July 2017


  • edited July 2017

    I am having the same problem as him. I can open existing projects but can not open new ones.I have tried reinstalling HitFilm with no luck.

    The project and export tab now don't work at all. Whenever I click any one of them, the application just lies there, making the application pretty useless if we can not export anything.

    I really hope a solution is found soon since I was so excited by getting mocha pro.


  • @MuuSer,

        I have 1 other thing to try. It's in performance options.

    Right click my computer and choose properties, then advanced system settings. On the visual effects tab, you can try and deselect "Animate Windows when Minimizing and maximizing". The best start would be to just select "Adjust for best performance" and then try the activation.

    I'll try to think of what else may be causing it.

  • @MuuSer

    I found this thread in the imaginer forums. It discusses using their "cleaner" to get a clean install and try again.

    The download link in that thread is broken. Here's the executable link from another thread there:

    Also note, that a few others talking about this and using this tool, have had to finalize by contacting their support (Listed in that first post). So be prepared.

    But I think if you can go that route, they will be able to help you best anyway.

    Good luck.

  • Hello @BurrManator and thanks for your time and care.

    Unfortunately your first advice did not helped and second one I had tried myself already. Also no good. Exact the same. Creates folders for licence file, but no licence file. Obviously it crashes before it can write it. I have no special restrictions for folders and I have administrator privileges also. I'm not the last dummy about computers as I'm a programmer but I have no idea, what causes this...

    I have contacted more than 24 hours ago with Imagineer support, but no answer yet except automated confirmation that they got it.

  • Triem23Triem23 Moderator

    @MuuSer First, don't worry about Imagineer License Manager--that's for floating licenses, like a studio with 12 terminals but only 6 licenses all on the same network, to allow ANY six terminals to run Mocha at a single time. It has nothing to do with the OFX version which is "node-locked" to a single machine.

    Sadly, I recommend patience for a couple of days with Imagineer. Today is the July 4 holiday in the USA, and it's also possible that Imagineer offices were largely closed on July 3. You probably won't get a response until July 5. Hopefully no later.

    Otherwise, the minimum system requirements for mocha are under those for Hitfilm, and you're over minimum spec for both.

    Humor me here and double check your GPU drivers are current. I can't imagine this would effect an online registration, but it can cause other Hitfilm problems, so it's always a safe thing to double-check.

    At least in LE mode you can go ahead and edit your projects, you just won't render them out until this is resolved.

    @Efrainf what are your system specs? CPU, GPU, OS, RAM and Storage? Just making sure you're over spec. Otherwise, read the above about Imagineer License Manager--don't need it, uninstall it.

  • I installed the OFX version and had no problem getting it up and running.  That being said, it was far from obvious, so a brief little tutorial would have been helpful.  

  • Triem23Triem23 Moderator

    I dunno... The fact that the actual Mocha Pro Plugin has License Management as an option when added to a layer made it pretty easy for me to find.

  • Hi @Triem23:

    Here are my specs:

    Processor:   Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz, 2401 Mhz, 4 Core(s), 8 Logical Processor(s)

    RAM: 16GB

    GPU: NVidia Geforce GTX 675Mx (4 GB)

    Disk Space: 375 GB of 750 GB

    OS: Windows 10

    I followed you advice and uninstalled the license manager.

    I am not really sure if this is a problem due to having two versions of mocha on the same HitFilm installation or something on the Mocha pro plugin that is affecting HitFilm. What worries me is that even by uninstalling, I can not get HitFilm to work again. It is like a registry entry in Windows is still messing with the installation (just a guess).

  • I assume that was a reply to my comment.  The problem I had, as with the OP, was sorting out what was going on with the Imagineer site.  Too many options and nothing that said "HitFilm".  As you say, activating the plug-in was straight-forward, once I figured out which version I needed.

    One last point, I would like to commend the HitFilm team on working out this offer.  Great price for Mocha. 

  • Triem23Triem23 Moderator

    @Xybor I was being snotty. I apologize. :-)

    Admittedly, the biggest issue for installation is figuring out that one needed the OFX plugin. Not made easier by the fact that Imagineer's website doesn't like Hitfilm as a compatible host, and Imagineer's product comparison page still is showing the Hitfilm 4 version of the Mocha Hitfilm plug-in. But that's at their end. FXHOME probably should have specified that it's the OFX plugin. :-)

    @Efrainf ok, you're over spec as well. So it's not that. (This is good, because being under spec would be a "it won't work, ask for a refund" situation..)

    Just a blind guess, but something probably glitched on your installation, and, as you seem to be thinking, something may be off in the registry.

    For the record, I currently have on this computer Hitfilm 2 Ultimate (and it's version of Mocha Hitfilm, based off Mocha 3), Mocha 3 Pro, Hitfilm Pro 3 and 4 (Mocha Hitfilm based off Mocha 4), Hitfilm Pro 2017 (Mocha Hitfilm based off Mocha 5) AND now Mocha 5 Pro. I've quickly gone into multiple versions of Mocha and done a quick test-track, and all versions are working.

    Hopefully Imagineer will help you solve the issue soon.

  • Hello @Triem23

    I have already submitted a ticket to HitFilm due to the fact that the plugin itself works but Hitfilm does not (at least two of the tabs). If they find a way to clear my registry properly, I'll be more than happy.

  • Mocha Pro VR ofx plugin-in works smoothly with Hitfilm Pro 2017 on my PC atm . 

  • One more thing to try.

    For nvidia drivers, go into driver and add hitfilm as a program and be sure to MANUALLY specify nvidia gpu as the device.

    If you dont understand, i can explain further.

  • @Triem23 ;


    Apparently there is an inconsistency on the Mocha site.     On the product page for Mocha Pro, Hitfilm is listed as an appropriate host.

    However, on the Product Compare Page, Hitfilm is indeed not listed.

Sign in to comment

Leave a Comment