Running like a slug [Solved]

edited April 2017 in Pro Support

Ok nothing has changed on my system and it has been running absolutely fine through Hitfilm 3 and 4 pro. However recently just opening up Hitfilm I end up waiting forever for even the splash screen to come up then when I select new it takes even longer to get to the video settings. After waiting forever for that to pop up then select composite shot it takes forever and half the time ends up unresponsive and windows wants to close it. As stated above I have not installed any programs nor downloaded anything from the time it has been working fine to now. No other programs on my computer are running this way either so I know it isn't a virus or malware or any other type of ware. Only thing I haven't tried yet is to uninstall it completely and reinstall.


  • Which version are you trying to open?

  • edited April 2017

    @inScapeDigital Hitfilm 4 Pro (update number 8)  is what I am using now and it ran fine before until recently. Am trying a repair right now, no idea what that would do but trying everything before uninstalling and reinstalling to see if it corrects itself. Also when it is hanging the taskmanager doesn't show any red flags for cpu or memory usage to indicate why it is lagging so badly.

  • I get the same problem from time to time on my new Windows machine. There seems to be a redraw hang...seems crashed....but if you wait a second everything thing seems to come out of "unresponsive mode". 

    The newest Nvidia driver for the 1070 seemed to be the culprit. Also effected ray-tracing in Element 3D. I retro graded my VC driver and everything seems to be ok now.

  • edited April 2017

    @GrayMotion           Yeah I understand a little hang here and there but this is more than a hang. Once I do finally get into the empty compositor, just adding a simple plane takes 5 mins or longer. To the point where doing anything is beyond even trying. All my display drivers are the same as they were when it ran perfectly fine before. Just seems as though one day it decided "forget you hippie, I am done working for you" and just doesn't function anymore. About the only other thing now that I think of it is there was a cumulative Win10 update and I guess I could roll back to the previous as long as the Nazisoft hasn't put an end to rolling back updates.

  • Triem23Triem23 Moderator

    And the Windows 10 update is your culprit. There's been a lot of users with the same issue. 

    Trying to remember which thread(s) have solution(s). 

    So glad I'm still on Windows 7.

  • @Triem23 Thank you so much, knowing that I am not the only one that has this issue. I will scan through the threads to see if I find anything on solutions. I was going to post a video of what exactly is going on but I don't want others on YouTube to think the software is to blame or shoot down using it because of what they seen in a YouTube video. Seems about right that Microsoft would do something like this, first (1607) anniversary update took away my ability to mirror to my 65" Samsung tv.

  • edited April 2017

    @Triem23 That is very interesting you are using W7, seeing  that ageing platform suffers from a number of serious failings including security deficiencies and hardware restrictions. e.g W7 doesn't support the latest AMD, Intel and Qualcomm chipsets etc, so you cannot run your PC's maximum hardware performance under W7, so you will not get the best and top performance from your chipset and hardware under W7.

    But it seems you are content :)

  • Triem23Triem23 Moderator

    @Yeremyah Skylake is fully supported by Microsoft till July, at which point Win 7 support becomes critical security updates only. 

    And this is better to me than mandatory updates in Windows 10 since roughly every three months the mandatory update causes issues that requires rollback. 

    I mean HOW many users/threads have there been in the last week about Hitfilm crashing that is directly related to Microsoft's terrible coding. Win 7 is still the last good version of the OS. 

  • Starnge, you know knock on wood ,so far I haven't seen this behavior with the Windows 10 updates.  Of course, my system was 8.1 and I took advantage of the free update back when they rolled it out so that might make some difference??  To date, the occasional message about the system updating is the only clue I've had that it even did it.  Now, with my Pinnacle Studio 18 & 19 Windows 10 gave me so many fits that I will not continue supporting it by upgrading.  Don't know for sure it was Pinnacle's fault but the problems didn't start until after Corel took it over so I blame them...

  • edited April 2017

    @tddavis yeah I started out with 8 on here then went to the 8.1 then signed up for the trial run of 10 and at first it was great till the (1607) updates started which is from what they call it the anniversary update. Then it all started going downhill. I am going to roll back to the last previous update and see if that don't help. Will probably post on it tomorrow.

    P.S. if I had it my way I would still be sporting Windows XP ;)

  • To disable windows 10 automatic update, open services.msc, find windows update service stop it and set it to manual or disable.

  • @FlyingBanana78  I hear you there.  I still have 32 bit XP on one of computers just because it was so stable.  I don't know what Update I have at all, I'll have to look into and see if I can figure it out. 

  • edited April 2017

    @Triem23 It all depends on the hardware of the person's PC when using Windows 10 whether they have problems with any updates.

    My Specs:

    Intel i5-6400 (Skylake) 2.70GHz
    8GB RAM
    NVIDIA GTX 960
    Samsung SSD 650 120GB

    And I have never needed to rollback a W10 update.  Everything, including HitFilm always works as expected after any W10 updates.

  • @Yeremyah

    I wrote Update not Upgrade

  • Ok issue fixed, I rolled back to the previous update before the issue and it seems to be doing fine now. So I will mark this one done now.

  • Just to clarify what I meant about the 1607 (redstone, anniversary) update I was talking about here is a little information about it.    ;

    So if you go to your settings then select update, you can select to view previous updates and that is where it will have the listings of what updates have been installed (successfully or failed) and you can look at them if any of them have 1607 listed then you are currently using the anniversary version. I had no problems with it till recently. I actually liked the update when it initially happened but as usual Microsoft can't keep a good thing good and they have to release updates to cause more headaches not thinking of other machines that may have issues with the update.

    Like for instance I have a friend that has a nextbook and it has win10 on it, thats all fine and dandy but he can't update it despite it constantly yelling at him he needs to cause the device itself doesn't have enough storage space for the update. Guess that is what keeps people buying higher end equipment and just tossing their old stuff cause it can't be used anymore except for a paperweight. *deep breath, ok rant done. Move along * :)

Sign in to comment

Leave a Comment