Error in Hitfilm Pro 3D Object Import

edited December 2016 in Pro Support

I was importing a .3ds file into hitfilm. Normally you see a second window opens showing your 3D models and the parts you can transform. However, for me The window does open, but it remains blank. As you can see in the screenshot below, it even enables me to click on various objects, but I just can't see it.


  • I have also tried using models of other formats, like. obj, but the same happens. I have the latest hitfilm update 1.

    My specs 

    Windows 10 pro 64 bit

    48gb ddr3 ram

    2x Intel Xeon x5570

    Nvidia GeForce GTX 1060 3gb

  • Hmmm.  Maybe this is what is happening to me.  I can't import 3D models or meshes, either.

  • This is odd, and I have to fall back on "are your GPU drivers updated?" I've just loaded two models into HFP 2017--one from Turbosquid, one that I built. Both have opened with zero issues.

    General notes on 3D models (and a note to myself to save this as a word doc, because this gets repeated--and this forum has terrible search):

    Hitfilm supports the BASE spec for it's 3D model types. Using OBJ as an example, this format goes back to the 1980's. OBJ itself is only geometry and requires a seperate file for material. The MTL spec for OBJ doesn't acctually support things like normal maps....

    Where I'm going with this is downloading models from online sites can often cause issues. The model may be built for things the modelling software supports, but the model spec doesn't. 3DS files are a good example here--a model built as a 3DS but using VRay might not import correctly into Hitfilm--VRay is a third-party render suite that supports things not in the 3DS spec. Consequently a VRay model might actually be "illegal" and Hitfilm will have issues.

    Moreover a lot of models from sites--especially free ones--may be, to but it bluntly, crap. You have models built by students or beginners who don't actually know what they're doing yet and models may have bad topography, polar verticies, or co-planar tris--all of which require cleanup before use.

    Vespill I don't know why your model import screen is showing solid white--that's unrelated to anything I've mentioned above, but I am wondering which models you and@DlKeur are opening?

  • @Triem23

    Thanks for the detailed response. 

    I have the latest drivers installed for everything. 

    I was opening free models from TurboSquid as well. (links below) You are absolutely right about the free ones being utterly poor.

  • edited December 2016

    I tried .3ds, .dxf, .obj, and .lwo    I don't get a white screen.  I get to see the files, select, then the window disappears as if...and then I'm staring at the interface with a question mark hanging over my head as nothing has happened.  ADD/EDIT: I am trying to pull files through the network from another storage drive, though, not from a drive on this local machine.

  • @Vespill Yeah, I used a free Turbosquid car model in my Ghostbusters GO! Short. I think I downloaded 20 different models and the one I used in the short was the only model that opened correctly without requiring a lot of retopo.

    Oddly enough that particular model has zero interior, but no one who's watched the thing has said "Hey! That car's got no seats!"

  • edited December 2016

    @Triem23 : Okay. Your sphere opened and imported just fine.  So why won't my .3ds files?  The window did the same thing I described above, except that your sphere imported, while I get nothing added to my imported media list when trying to import mine.

  • @Vespill and @DLKeur There might be something else going on because I can import the models Vespill linked to without issue

  • @Aladdin4d @Triem23

    I have raised a support ticket as it seems to be a problem only on my system. Most likely they will tell me to reinstall Hitfilm, though.

  • @Vespill I'm sure and right now I don't have any other advice because every time I've had a problem importing a model it's been a problem with the model itself

  • @Aladdin4d , @Vespill : Okay. I'm going to stop what I'm doing (client won't be pleased, but, hey....)  and I'm going to try some experiments to see if I can get something to import. It may be a network issue on my end, or it may be the customizing I did to the meshes. I'll try some defaults and see what happens. Will report back in awhile.

  • edited December 2016

    Okay. They ARE importing after copying them and pulling them through the network from the storage drive to the local machine's E drive.  I just did it with .3ds files, and those files are saved at my custom settings and are intricate meshes.  Step one figured out.  Now to try some other formats and also some models. Cool.

  • @DLKeur If you have a model that's safe to share (and you're ok with sharing it) I can see if it will import for me and I'm sure if he has time @Triem23 would be willing to try it as well.

  • @Aladdin4d : Okay.  All right.  Sorry.  I was trying a bunch of different things.  If you guys want to play with one of my models, that's cool.  This is one from Dec last year of the z-com logo.  It's really ugly, though, especially when brought into HitFilm.  I'll jerk back over through the network some of my more intricate ones if you want, but they're not small files by any stretch of the imagination.  Anyway, here's the link for one:

  • Okay. Nix me on this problem. It was all caused by pointing to objects and models located on our in-house server. Importing the images and saving them to a storage drive on the local machine allows me to import all formats. Very excited by this. Sorry to bother everyone. I even got my monster planetary terrains to import, though HitFilm did seem to gulp at doing it.

  • @DLKeur it's still good to know that Hitfilm might have issues pulling media off servers instead of local drives. I don't have my own network set up so this isn't something I can test, but I'm wondering if that's also what's affecting @Vespill

    Either way let's tag @Ady for a quick question. Ady should Hitfilm be able to read media (say a 3D model) from a networked server correctly, or does Hitfilm want everything on a local drive? 

  • edited December 2016

    "should Hitfilm be able to read media (say a 3D model) from a networked server correctly"

    If answered, that should be an interesting answer. Given the transparency of the file I/O subsystems.

  • @Triem23 ;

    I do not have a network either, so it can't possibly be the reason for error. I am almost 95% sure that Hitfilm did not install properly or is somehow corrupted and is unable to display the 3D model window. 

  • @Triem23 : One thing to know about our in-house server. It's running Unix, not Windows. That might be part of the issue.  While our local machines here don't have a problem, I do have problems with Microsoft Office files. I have to import those, too, or Word, Access, and Excel all throw fits and even crash.

  • @DLKeur thanks. That's good info for the devs. :-) I wouldn't be surprised if the Unix/Windows thing is the root of your issue. Now if we can figure out what is going on with Vespill... 

  • edited December 2016

    I'm wondering if @Vespill 's issue isn't driver-related or RAM related.  On some of my graphics software, I'll get a blank, white window happening when the driver corrupts. Reinstalling the driver with a fresh copy solves it.  RAM related issues, especially on resource hogging unstripped Windows OSs is also a problem, so I'd check your resource meters and see if Microsoft or some other program isn't hogging your RAM or bogging down your CPU. Another culprit can be syncing if you've got that switched on. Turn it off and see if that helps.  ADD/EDIT: The reason I'm suggesting this, @Vespill , instead of HitFilm's install being the issue, is because HitFilm seems to install very neatly. It doesn't splatter itself all over the C Drive, and its use of resources is very light.

  • @DLKeur ;

    Yes indeed that could be the most plausible culprit , because the UI works perfectly fine. I will see what I can do with my gpu drivers and also see suggestions from tech support. 

  • While importing in Hitfilm Pro 2017 doesn't show obj files to import , but shows the video files. It imports mp3 but shows error. 

    In the import box  (all files) doesn't include  obj files and other 3D files. What do i do?

  • Triem23Triem23 Moderator

    @Kaviyarasu next to the Import button is a small arrow. Click that to open the menu for "special media" then select Import 3D model. 

  • @Triem23 . Thanks that works.

Sign in to comment

Leave a Comment