Launching HitFilm Pro 2017 gives me an error message and won't start (Resolved)

edited December 2016 in Pro Support

Trying to launch the app always ends with the "encountered a problem and has to shut down" message.

Tried it on my back up computer with all over lower specifications,

no problems what so ever.

I also have HitFilm 4 installed and never had any problems with that.

I've tried re-installation, restart of both versions in all different combinations. NO LUCK!

It's an Asus laptop

processor i7 4700 2,4ghz

ram 12gb

gpu nvidia 850



  • Hi @luddefalk,

    Thanks for providing the specs up front, that's really helpful. Could you also double-check that your graphics card drivers are up to date? If your laptop also has an integrated graphics card, please make sure HitFilm isn't using this rather than the Nvidia 850.

  • edited December 2016

    The drivers are up to date.

    I've tried starting the app with both the nvidia 850 and the integrated gpu, neither works.

    My backup computer only have an integrated gpu and it has no problem launching the app.

    I've also tried launching the app without my wacom connected, but it made no difference.

    I only have the adobe suite , clip studio paint, and some random players installed, and running windows 10 and i have not heard about any conflicts.


  • Just a shot in the dark- did you try a complete fresh install by deleting all related HF2017  files and folders from the Programs folder after uninstalling? Don't know if that would help but might be worth a shot if you didn't already go through those steps.

  • edited December 2016

    Tried that a couple off times, no success.

  • @luddefalk do you have any 3rd party plug-ins installed that could be causing the problem?

    Also, if you could submit the crash report to us (and tag it with your name or email address), we may be able to pick something up in there.

  • Problem solved!

    I finally got it to work!

    Photoshop cc2017 did not start either,  and i found a solution on

    a photoshop forum.

    I uninstalled Lava web companion and boom, everything works.

  • Hoorah! Glad you got it sorted.

This discussion has been closed.