HELP! Cant export... 2 hours past deadline.

edited August 2016 in Pro Support

On a mac using pro trying to export proves 422 1080p at 30fps. My computer is in spec. Here is the header for crash report.

Also received this when trying h.264 Shot 2016-08-05 at 2.08.02 AM.png?dl=0

Process: HitFilm4Pro [29850]
Path: /Applications/HitFilm 4
Identifier: com.fxhome.HitFilm4Pro
Version: 4.0.0522 (4.0.0522)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: HitFilm4Pro [29850]
User ID: 502

Date/Time: 2016-08-05 02:05:10.220 -0400
OS Version: Mac OS X 10.11.6 (15G31)
Report Version: 11
Anonymous UUID: 9AC17478-70F1-42DA-E260-9DB86512C58D

Sleep/Wake UUID: 6852AED1-D947-474B-B3A9-3EFA0FA1CEB5

Time Awake Since Boot: 80000 seconds
Time Since Wake: 18000 seconds

System Integrity Protection: enabled

Crashed Thread: 28 Dispatch queue: com.fxhome.fxmedia.avwriterdispatchqueue

Exception Codes: KERN_INVALID_ADDRESS at 0x000007fb98060ca8

VM Regions Near 0x7fb98060ca8:
mapped file 0000000163556000-0000000164c1c000 [ 22.8M] r--/r-x SM=ALI
JS JIT generated code 00002f4ff3000000-00002f4ff3001000 [ 4K] ---/rwx SM=NUL

Application Specific Information:
objc_msgSend() selector name: retain


  • Triem23Triem23 Moderator
    edited August 2016

    This will either require staff attention or one of the supertech squad ( @Aladdin4d @NormanPCN @Stargazer54 )

    Immediate suggestion. Try rendering an image sequence. Less overhead to render, then you can import the image sequence on your editor timeline, mute everything else video-wise and go to Prores from there since you've effectively turned it into a transcode.

    What's the project? What's going on in the timeline? 

    Since the crash is showing as in the "avwriterdispatchqueue" it looks like the issue isn't the frame render but the file write. Another thing about an image sequence is, if it crashes halfway through you don't re-render the first half again, but start on the aborted frame. 

  • edited August 2016

    Wasn't even able to render an image sequence : / no export is working.

    Heres a link to screen shots of the Timeline. I guess I can try save the prjoect to a USB and try exporting it upstairs on my pc tomorrow... another late Film Riot Monday Challenge I suppose haha. I have yet to be able to submit one on time lmao @Triem23

  • I have work in 4 hours so time for sleep. Hopefully a DEV will know what's up :)

  • Triem23Triem23 Moderator

    If it makes you feel better I didn't have a suitable idea for a good suspense short until Monday, which I didn't do since I need a cast of... 8 to 10...

  • This is definitely one for a Dev. EXC_BAD_ACCESS usually means trying to access a deallocated object or the object didn't initialize properly to begin with

  • edited August 2016

    @TriflixFilms - you mentioned  a link to screenshots of the timeline. Can we get that link please, so we can see what specifically is happening on the timeline?

  • edited August 2016


    Green screen footage, set to matte (sillohettes), still background, composite pokeball (Just colored planes) added in with motion blur.

    This was suppose to be an easy quick turn around with no special effects or craziness.... just a simple narrative with a stylized visual to match it.

  • Are you able to render proxies of the two composite shots? And if so, can you do so, and then see if the export works?

    It is the Editor timeline that you are trying to export, right?

  •  Yeah @axelwilkinson the editor. I'll try that tonight :)

  • Soo.... I delete the sillohetes (the only real footage I shot) and it works now...

    However, I have no footage. 

    My camera records h.265 and I found a free converter for prores 422...

    Nightmare. @axelwilkinson

  • Sorry, I was still waiting for the answer to this question: Are you able to render proxies of the two composite shots? And if so, can you do so, and then see if the export works?

    You also mention that you found a free converter for ProRes. did converting the footage have any affect at all?

  • edited August 2016

    I created proxies for all of them except 'composite 1' kept failing.

    "Soo.... I delete the sillohetes (the only real footage I shot) and it works now..."

    The footage is NX500 h.265 converted to prores 422 @axelwilkinson

  • @TriFlixFilms - you mentioned in another thread that you are still having issues here? Your latest post here says that the export is working now, so I'm just checking in to see what the status is. Is it working, or do you still need assistance?

  • edited August 2016

    Goodness I have the worst choice of words when conveying messages hahaha (Midwest jargan I suppose).

    I will screen cap what is happening when I get home tonight and try to share it on here by 8:30 (4 hours from now). Essentially my recorded footage is not exportable but the images and audio is, so... a video without footage isn't very entertaining haha.

    If that still doesn't make sense, hopefully the screen cap will clear things up. @axelwilkinson

  • Here is the screen cap, I suggest watching at 1.5 speed haha


  • Thanks for the link. If your footage is shot at 60fps, is there a reason you aren't exporting to that frame rate? If you do, do you still see a crash?

    If you remove the effects from the footage, does it still crash on export?

Sign in to comment

Leave a Comment