Boris Text disappearing after 1 frame

edited July 2016 in Pro Support

Hello everybody,

Today I installed the Hitfilm 4 Pro update. Now my the title that I created with Boris is gone. I thought it would be a good idea to hit the 'register' button in the effect controls.

This is sending me to the Boris website where I then created an account. But I can't find any hit how to register the Boris Continuum Complete stuff.

Is here anybody who has this issue and know how to fix this?




  • edited June 2016

    I have a project that used Boris Extruded Text  and Extruded spline. That project is now all messed up when I open it in the new update.

    Very bizarre. At the first frame everything Boris is there. On subsequent frames everything Boris disappears. There is no keyframing.

    If I "reset" the BCC Extruded text, I still get the same thing. It disappears after the first frame.

    My stuff is in a comp and not on the NLE timeline.

  • edited June 2016

    At this very moment I'm chatting with a guy over at

    If we figure out a solution I keep you updated.

  • edited June 2016

    I rebooted my machine and the project that had a problem opening now seems okay. I had not rebooted after installing the update and I opened this project after reading your post. The reboot was worth a try and it seems to work for me.

  • edited June 2016

    I had several reboots since the update. I just sent the project file to the expert of BorisFx.

    UPDATE 1: 

    Gosh, just had thunderstorm and now my living room is under water. Have to take care of that first.

    The recommendation by BorisFx is, uninstalling Hitfilm and installing it again.

    UPDATE 2:

    I now tried to run the update again and chose the repair option. Didn't made any difference.

    The weird thing is that the project file that Jon from BorisFx sent back to me worked.

    Now I consider removing Hitfilm 4 Pro and installing it again. Do I have then to run the update again as well?

  • The "update" is a full installation file so just running the install should be enough to install from scratch.

  • edited June 2016

    OK, this is a real bug. Here is what I found:

    1. I uninstalled Hitfilm 4 Pro and Ignite.
    2. I re-installed Hitfilm 4 Pro again and the BorisFx text worked again.
    3. After also re-installing Ignite, the BorisFX text is gone again and doesn't work.

    Anybody else with this phenomenon?

    UPDATE: I will create a support ticked on this because of repeating all the above the problem persists.

  • edited June 2016

    Sorry to hear you are having troubles with the update, @MarioKluser. Can you give us some details about your system, please? Preferably, contact HitFilm support with the project file and the following details of your system:

    Graphics Card:

  • edited June 2016

    Hi Alex,

    I just sent a project file when creating a support ticket.

    OS: Windows 10
    CPU: AMD FX-4300
    Graphics Card: NVIDIA GeForce GT 730
    16 GIG
    All HD's are SSD

  • AdyAdy Staff

    MarioKluser - Sorry to hear that you are having trouble with the software.

    Installing HitFilm Ignite will have no influence on what happens in HitFilm 4, they are entirely separate products.

    I have tested your Project this morning & the Project you sent loads fine for me & playback shows the Effect correctly.

    I would suggest looking to update your GPU drivers as the next step.

    Nvidia GT 730 Driver


  • edited June 2016

    Thanks Ady,

    I just updated the drivers for the GPU, but the problem is still there.

    Nothing shows up and when I create an entirely new text with Boris it will show up for one frame only.

    The version that Jon from BorisFX sent me doesn't work anymore either. It worked one time. Trying to find the logic here.

    I will probably try to uninstall Hitfilm again and have a look if I have the former version and install this one instead.

  • AdyAdy Staff

    MarioKluser - What Render mode (Anti Aliased, Full, Half or Quarter) is the Viewer set to? I noticed on your Project it's set to Half. If it's on Half or Quarter, when you switch to Full does the Render return?

  • @Ady, I just tried that without a result. I also tried exporting it to an MP4 to see if it works somehow in the background. It doesn't.

  • AdyAdy Staff

    MarioKluser - Well that's very odd indeed, you say it shows for one frame & one frame only?

  • @Ady Yes, it shows one frame only. 

  • As an aside: 'Old' Boris never worked properly in Half or Quarter mode in the Viewer either.

  • @Palacono That was a bug in Hitfilm and it was fixed a couple of updates after the release of 4. The problem existed in Hitfilm 3 with plug-ins like NewBlue Titler Pro. I reported it back then but never got any traction until the release of 4 with BCC.

  • @NormanPCN As you had a similar problem, could you provide your general Hitfilm Settings, like cache a.s.o.

    Maybe it's somewhere in the basics.

  • Sure,

    • Windows 7, i7 4770k 4Ghz, 16Gb RAM
    • Nvidia 980 4GB, driver 368.22
    • Hitfilm 4 cache "c:\Hitfilm\cache\"
    • proxy "c:\hitfilm\proxy\". no proxies exist.
    • Ram preview 2048, 8x MSAA. other options remain at defaults
    • test project is 8-bit. 1080p29.97 fps. 100% CG. no media files.
    • Boris objects (extruded text (1 layer), extruded spline (4 layers)) are applied to separate plane layers. All 2D. They all exist in a comp of 7 seconds.

    To repeat myself, when my installation was exhibiting the reported problem it also showed the single frame thing. The first frame was fully working and after that the Boris stuff disappeared. A reboot after the Hitfilm update "fixed" the issue on my installation. I use the word "fix" loosely since I cannot explain exactly why the reboot changed the observed behavior. 


  • @NormanPCN

    You just solved it!

    Only when a project is loaded the Default Anti Aliasing option is showing in the Option's panel.

    I changed it from 4x MSAA to 8x MSAA and restarted Hitfilm and now it works.

    But note:
    When I now change it back to 4x MSAA it still works. Not matter in what quality I choose to play it in the viewer.

    Therefore I assume that the most important thing is to safe the program's option settings again while a project is loaded. However, this  workaround of setting it to 8xMSAA works and knowing that you can change it again in whatever you please is an aside.

    You just totally made my day!

    AxelWilkinson please have a look at the above, so you don't have to dig further for a workaround.

  • @MarioKluser Okay, I'll accept credit. Where's my cookie! 

    Boris says they are an OpenGL app and they will setup the GL context separately for themselves. Maybe some setting is getting confused/clobbered across GL context switches between Hitfilm and Boris. Maybe Hitfilm saved some context setting from the old Boris across to the new and that caused some confusion.

    Maybe, maybe, maybe. Anyway, you've got a reasonable workaround if it ever comes up and that is the most important thing.

  • @NormanPCN The cookie is in the browser, lol. :-)

    There were so much what just didn't make any sense. So it wasn't wrong to search somewhere in the basics. I guess we will never know what was the reason for the confusion, but what matters is that it works now.

    Have a great weekend!

  • @MarioKluser "The cookie is in the browser, lol. :-)"

    I can't claim credit for setting that one up.

  • edited June 2016

    Update: It was just gone again. After I then turned the applied LUT and Auto Lens flare off and restarted Hitfilm it came back. After that I could apply all the above again.

    I think in the future I will render the whole thing out to a PNG-sequence and then convert it back to DNxHD before using it in the project. This way the I make sure that the text is there and it has the advantage of less clutter in the project, what makes a faster render and workflow. 

  • I bought HitFilm4Pro yesterday and have the same problem. Initially title was visible on the first frame only. After registering BorisFx plugins on their site it was working without any problems. Today title is visible on first frame only. Changing Anti Aliasing settings doesn't work for me.

  • I am also having the same issue with Boris FX. Text not visible after the first frame in a project.I tried an Uninstall/ reinstall but the issue still persists. I opened a new project with only the Boris and it still vanished after the first frame.

  • Hello, I had the same issue on my laptop and on my studio computer. On the laptop everything went fine after I changed the antialiasing setting, but not on the studio computer. There, I updated the NVidia graphics driver and it solved the problem. Now everything's ok. Hope this couls help...

  • I also had this problem but I tried what worked for @MarioKluser which was to go to File>Options>General and set the Default Antialiasing Mode to 8xMSAA and then closed and opened Hit Film and Voila! There it was!

    Thank you @NormanPCN for directing me to this thread with such a quick response time! What type of cookie would you like? Chrome perhaps?

  • AdyAdy Staff

    Hi guys,

    We've been able to reproduce this problem & are currently looking into what is causing it. I apologize for any inconvenience caused & will naturally update you all when I have more information.

    It should be noted that it does not appear to be related to the aliasing method your project is set to.

    Kind Regards,

  • Thanks Ady, this problem is a bit annoying !

  • Hi, I had Tech support (who are awesome by the way) trying all last week to assist me with this Boris text issue. Ultimately, they could not replicate the issue I was having. However, an odd workaround has allowed me to get past the text disappearing after the first frame: I created a New comp with only Boris Continuum on a Plane Layer. I chose extruded text. I typed the word "Sample Text"  ( I think any letters would do). and sent this to support so they could see the problem. After I sent the project file, I saved a copy to my desk top and opened it. the frame issue no longer occurred.

    Now when I want to do a project, I open that saved project file on the desktop, then go to File > New>to create  a new project and Start compositing  leaving the original desktop HFP file alone. Seems strange, but It has worked at least for me so far.

Sign in to comment

Leave a Comment