Composite Shot Strange behaviour - Bug or User Error?

I've not really played with embedding composite shots, I tend to just do everything I want in  a single composite, as they're not that complicated, but I just embedded one and got some unexpected behavior afterwards.

Q: If I have a layer with a couple of effects on it and make it into a composite shot (Right Click, Make Composite) and the layer is replaced by the reference to the New Composite, should I expect the original Composite to simply act EXACTLY as it did before?

I did think that was the point:  rolling groups of things up into a Composite, which means you keep things tidy and you can Proxy them to keep the render speed up etc., but it doesn't work for this example.

I tried it in HF3P and HF4P (Demo) and I get the same (different) behaviour, which breaks the original composite.


  • edited January 2016

    I've not had any problem with embedded comps. What options did you choose when creating the composite? Leave effects/masks/etc here or move with layer. I have always used move with layer since I want the created composite to be exactly like it exists in the current comp.

    After that, then you can add additional mask and effects to the embedded comp layer should that be desired.

    When making a single layer a new comp you are given the option to leave mask/effects/etc or move with layer. When you select multiple layers to create a new comp, the masks/effects always move with the layers to the new comp.

  • All I had were 4 layers in a simple Composite. Camera, Point, Plane and Text. Everything is 3D.

    The Text had a couple of Effects on it and it had the Point as its parent and there are a few Keyframes on the Text and the Point.

    I Right Click > Make Composite Shot on the Text Layer. There are no options, just a name box and info to say it'll all get moved into the new composite.

    The Text Layer moves, a Camera is created in there with it and it's replaced by a new Composite Layer in the Original Composite.

    Playing through the Original (with the new embedded) Composite Layer does not give the same results as before.

    I'll make up a quick video and upload a project file somewhere if this is not supposed to happen.

  • Triem23Triem23 Moderator

    Ah... The new camera created won't have any movement attributes of the original camera. If your embedded text comp is in 2D mode then it's giving you a nice image of text and a still camera. Try changing the embedded comp's composite mode to 3D unrolled to promote it's 3D positioning of text to the main comp, or copy main comp camera to tge embedded comp. 

  • edited January 2016

    @Triem23 Thanks for the assistance. I copied the camera from the original comp into the second one and deleted the original 'new' camera. Then made the embedded comp have the point as its parent again (as that had been reset to None) then set it to 3D unrolled (as that had changed to 2D).

    It broke even more, as there was no movement of the embedded comp (which previously has some angle changes). Changing it to 3D plane got the movement back, but it's still broken.

    I'll knock up a video, upload a project somewhere.

    I'm sure the problem is something like "When you embed a comp you also need to do X,Y,Z for it to act just like the layers it originally consisted of (preposition error alert!)", but I'm not sure what X,Y and Z are (and they're not only what you described, unless I missed one)

  • edited January 2016

    @Triem23 , OK, I solved it. In the Text Layer, I had an Effect (Shatter) that was using a Transform From of the Point.

    But, I had not included the Point when I did 'Make Composite' of the Text Layer, so there was no Point in the New composite to Transform From and there is no way to do that with the new embedded composite of the Text Layer back in the original composite. But, copying the Point over and then 'Transform From'ing it again and all was well.

    Also just selecting both before doing the 'Make Composite' included it automatically, which is obviously the proper way to do it with multiple layers, which I'll bear in mind in the future.

    My mistake was in assuming all the references and dependencies would be maintained across multiple composites, and a way to do this might be useful. Is there really a reason why they can only reference elements within a single composite? It's only an extra layer of indirection.

    But, if not practical (or complicated, but I doubt it, most programs deal with this sort of thing virtually ad infinitum) how about having something let you know what was going on when you do 'do it wrong'?

    Some sort of log generated that said "Referenced Layer: "Rotation Point" removed from Text Layer "Title Text": Effect>Shatter during "Make Composite" process" would have (ahem) pointed me in the right direction earlier.

    It would also help if when doing this with a much more complicated sequence of layers with more inter-dependencies, or I (or you) could be searching for hours to find the 'missing' reference.

  • I think an "are you sure" warning dialog, stating that there are referenced layers not in the selected items to be moved to the new comp. This dialog would have a prompt asking if you want those items also moved. To be informative the dialog could have a list box giving the referenced layer names.

  • @NormanPCN, Yes, something along those lines would be useful, and I doubt very complicated. After all, the program's already find the missing references and resetting them to 'None', so to tell you it was doing it (or about to) is only being polite.

  • Triem23Triem23 Moderator

    It should be a dialog option next to Attributes and Effects. "Links." Copy, Move, Leave Here. All three modes have their uses, and then it makes you choose (i.e. think "does this link to anything?") before hitting ok. Sometimes I DO want to detatch a layer from its points. 

  • @Triem23 from your mouth keyboard to the developers' ears eyes.

  • @Triem23 Post it to the wishlist...

Sign in to comment